Project

General

Profile

레드마인에서 메일전송이 안되요!

translation missing: en.label_added_absolute_time_by

 위 링크에서 나온 방식대로 진행을 하였고, 구글계정을 새로파서 아이디를 등록해서 imap을 사용하도록 설정했습니다.  하지만 관리자로 로그인한뒤, 관리 -> 설정 -> 메일알림으로 들어가서 새로판 구글계정을 발신메일 주소로 넣어서 테스트로 메일을 보내면

 메일을 전송하는 과정에 오류가 발생했습니다. (execution expired)

 

라는 메시지가 뜹니다. 당연히 gmail도 수신받지 않았구요. 

 

분명 초기설정, 해야할것들을 다 끝낸것 같은데 안되는 이유를 도통 모르겠습니다. 

그래서 제 질문은

 

1. execution expired가 어떨때 나타나는 경고문인가?

2. 혹시 진행과정에서 빠져먹은게 있는가?  

 

ps:

email_delivery:

    delivery_method: :smtp

    smtp_settings:

      

      address: smtp.gmail.com 

      port: 587

      domain: example.net 

      authentication: :login

      user_name: "xxx@gmail.com"  

      password: "xxx"

현재 configuration.yml에 기입한 부분입니다. 그리고, 

 

production:
  email_delivery:
    delivery_method: :smtp
    smtp_settings:
      enable_starttls_auto: true
      address: "smtp.gmail.com"
      port: 587
      domain: "smtp.gmail.com" # 'your.domain.com' for GoogleApps
      authentication: :plain
      user_name: "your_email@gmail.com "
      password: "your_password"

위 기입한 부분에서 production에 이것도 추가로 기입했습니다.

ps: 링크가 잘못됬었습니다.. 다시 올렸어요.


Replies (1)

RE: 레드마인에서 메일전송이 안되요! - translation missing: en.label_added_absolute_time_by

default:
  # Outgoing emails configuration
  # See the examples below and the Rails guide for more configuration options:
  # http://guides.rubyonrails.org/action_mailer_basics.html#action-mailer-configuration
  email_delivery:
    delivery_method: :smtp
    smtp_settings:
      address: smtp.gmail.com
      port: 587
      domain: smtp.gmail.com
      authentication: :plain
      user_name: "xxxxxxx@gmail.com"
      password: "xxxxxxxxx"

혹시 설정한 위치가 다를 수 있어서 configuration.yml의 11라인에 설정했습니다.

그리고 Gmail 보안설정에서 보안 수준이 낮은 앱에 대한 계정 액세스 변경을 설정해 주셔야 합니다.

https://support.google.com/accounts/answer/6010255?hl=ko

    (1-1/1)
    Add picture from clipboard (Maximum size: 500 MB)