redmine에 ckeditor plugin을 설치하고 실행하려는데 tcpdf 오류가 발생합니다.

김 용철이(가) 2015-11-08에 추가

안녕하세요?

Raspberry Pi 2 에서 Ubuntu 15.10 환경입니다.
아래와 같이 마이그레이션을 실행하려는데 오류가 발생하는군요.
경로와 관련된 문제로 보이는데…

/usr/share/redmine/lib/plugins/rfpdf/lib/tcpdf.rb 가 존재하고 있습니다.
루비를 잘 몰라서 디버깅이 어렵군요..

고수님들의 조언을 부탁드립니다.
참고로 redmine은 3.1.1 입니다.

모든 설치가 끝나고 아래 명령을 실행하면 아래와 같은 오류가 표시됩니다.

/usr/share/redmine$ rake redmine:plugins:migrate RAILS_ENV=production

[DEPRECATION] requiring "RMagick" is deprecated. Use "rmagick" instead
rake aborted!
LoadError: No such file to load -- tcpdf
/usr/share/redmine/lib/redmine/export/pdf.rb:20:in `<top (required)>'
/usr/share/redmine/lib/plugins/redmine_ckeditor/lib/redmine_ckeditor/pdf_patch.rb:1:in `<top (required)>'
/usr/share/redmine/lib/plugins/redmine_ckeditor/lib/redmine_ckeditor.rb:135:in `<top (required)>'
/usr/share/redmine/lib/plugins/redmine_ckeditor/init.rb:2:in `block in <top (required)>'
/usr/share/redmine/config/initializers/00-core_plugins.rb:12:in `eval'
/usr/share/redmine/config/initializers/00-core_plugins.rb:12:in `block in <top (required)>'
/usr/share/redmine/config/initializers/00-core_plugins.rb:2:in `each'
/usr/share/redmine/config/initializers/00-core_plugins.rb:2:in `<top (required)>'
/usr/share/redmine/config/environment.rb:14:in `<top (required)>'
Tasks: TOP => redmine:plugins:migrate => environment
(See full trace by running task with --trace)

첨부 파일은 redmine을 웹으로 접속시 나타나는 화면입니다.
html이므로 브라우저에서 여시면 보입니다.

ckeditor.html Magnifier (92.5 KB)


답글 (2)

RE: redmine에 ckeditor plugin을 설치하고 실행하려는데 tcpdf 오류가 발생합니다. - 커뮤니티 관리자이(가) 2016-07-01에 추가

너무 늦은 답변입니다만 혹시 해결하지 못하셨다면 아래와 같이 해 보시기 바랍니다.

에러 내용은 tcpdf 라는 gem 모듈이 없어서 나는 에러입니다.

bundle install를 실행시키시면 자동으로 설치해 줍니다.

그럼 참고하세요.

RE: redmine에 ckeditor plugin을 설치하고 실행하려는데 tcpdf 오류가 발생합니다. - 김 용철이(가) 2017-05-09에 추가

ckeditor plugin과 ruby 버전간의 문제인 것 같습니다.

ckeditor plugin 페이지의 플러그인 버전과 ruby 버전 redmine 버전이 모두 중요한 것 같습니다.

이 3 가지의 버전을 제대로 하여 설치하니 정상적으로 동작합니다. 

    (1-2/2)
    클립보드 이미지 추가 (최대 크기: 500 MB)