Project

General

Profile

Question 플러그인 설치 시 에러가 발생합니다.

translation missing: en.label_added_absolute_time_by

<p>안녕하세요.</p>

<p>먼저 환경은 다음과 같습니다.</p>

<p>1. OS : Windows 7 x86</p>

<p>2. Bitnami Redmine 3.4.4-1 (Windows installer로 설치)</p>

<p>3. Question Plugin은 &#39;git clone&nbsp;https://github.com/edavis10/question_plugin&amp;#39; 으로 받았습니다.</p>

<p>&nbsp;</p>

<p>이후 Bitnami Redmin Stack Environment 에서 아래의 메시지들이 출력됐습니다.</p>

<p>Microsoft Windows [Version 6.1.7601]<br />
Copyright (c) 2009 Microsoft Corporation. All rights reserved.</p>

<p>C:\Bitnami\redmine-3.4.4-1&gt;cd C:\Bitnami\redmine-3.4.4-1\apps\redmine\htdocs\plu<br />
gins</p>

<p>C:\Bitnami\redmine-3.4.4-1\apps\redmine\htdocs\plugins&gt;rake redmine:plugins:migr<br />
ate NAME=question_plugin VERSION=0 RAILS_ENV=production<br />
(in C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs)<br />
<span style="color:#FF0000;"><strong>rake aborted!<br />
NameError: uninitialized constant QuestionHooksBase::Gravatarify</strong></span><br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/lib/quest<br />
ion_hooks_base.rb:3:in `&lt;class:QuestionHooksBase&gt;&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/lib/quest<br />
ion_hooks_base.rb:1:in `&lt;top (required)&gt;&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/lib/quest<br />
ion_issue_hooks.rb:1:in `&lt;top (required)&gt;&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/init.rb:3<br />
:in `&lt;top (required)&gt;&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/lib/redmine/plugin.rb:155:in `blo<br />
ck in load&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/lib/redmine/plugin.rb:146:in `eac<br />
h&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/lib/redmine/plugin.rb:146:in `loa<br />
d&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/config/initializers/30-redmine.rb<br />
:21:in `&lt;top (required)&gt;&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/config/environment.rb:14:in `&lt;top<br />
&nbsp;(required)&gt;&#39;<br />
Tasks: TOP =&gt; redmine:plugins:migrate =&gt; environment<br />
(See full trace by running task with --trace)<br />
&nbsp;</p>

<p>&nbsp;</p>

<p>Rake Aborted 에러가 발생하는데 어떻게 해결해야 할까요...</p>

<p>구글링으로 아무리 찾아봐도 해결되는 방법이 없네요</p>

<p>도와주세요!</p>


Replies (5)

RE: Question 플러그인 설치 시 에러가 발생합니다. - translation missing: en.label_added_absolute_time_by

아래 명령어 실행을 레드마인 설치 root에서 해 보실래요?

cd C:\Bitnami\redmine-3.4.4-1\apps\redmine\htdocs\

rake redmine:plugins:migrate NAME=question_plugin VERSION=0 RAILS_ENV=production

그런데 위의 명령어는 설치 명령어가 아니라 제거할 때 사용하는 명령어입니다.

설치명령어는 아래와 같습니다.

rake redmine:plugins:migrate NAME=question_plugin RAILS_ENV=production

RE: Question 플러그인 설치 시 에러가 발생합니다. - translation missing: en.label_added_absolute_time_by

답변 감사드립니다!

제가 로그 복사하다가 지우는 과정 메시지로 잘못 올렸네요;

 

일단 알려주신대로 아래의 명령어를 실행했습니다.

cd C:\Bitnami\redmine-3.4.4-1\apps\redmine\htdocs\

rake redmine:plugins:migrate NAME=question_plugin RAILS_ENV=production

 

이번엔 다른 에러 메시지가 발생하네요..ㅠㅠ

 

C:\Bitnami\redmine-3.4.4-1\apps\redmine\htdocs\plugins>cd C:\Bitnami\redmine-3.4
.4-1\apps\redmine\htdocs\

C:\Bitnami\redmine-3.4.4-1\apps\redmine\htdocs>rake redmine:plugins:migrate NAME
=question_plugin RAILS_ENV=production
Could not find gem 'webrat x86-mingw32' in any of the gem sources listed in your
 Gemfile or in gems cached in vendor/cache.
Run `bundle install` to install missing gems.

다시 한번 도움 요청 드립니다...^^;

 

RE: Question 플러그인 설치 시 에러가 발생합니다. - translation missing: en.label_added_absolute_time_by

webrat x86-mingw32 라는 Gem이 없어서 에러가 발생했습니다.

bundle install 이라는 명령어를 실행시켜 보세요.

정상적으로 실행되지 않으면 다시 안내메시지가 나올 겁니다.

즉 안내메시지에 따라 대응을 해 주시면 됩니다.

RE: Question 플러그인 설치 시 에러가 발생합니다. - translation missing: en.label_added_absolute_time_by

<p>답변 감사드립니다!</p>

<p>bundle install</p>

<p>이후에 처음 문의드린 에러 메시지가 발생합니다 ㅠ</p>

<p>&nbsp;</p>

<p>C:\Bitnami\redmine-3.4.4-1\apps\redmine\htdocs&gt;bundle install<br />
Fetching gem metadata from https://rubygems.org/...........&lt;br />
Fetching gem metadata from https://rubygems.org/..&lt;br />
Resolving dependencies...<br />
Using rake 12.3.0<br />
Using i18n 0.7.0<br />
Using minitest 5.11.1<br />
Using thread_safe 0.3.6<br />
Using tzinfo 1.2.4<br />
Using activesupport 4.2.8<br />
Using builder 3.2.3<br />
Using erubis 2.7.0<br />
Using mini_portile2 2.3.0<br />
Using nokogiri 1.8.1 (x86-mingw32)<br />
Using rails-deprecated_sanitizer 1.0.3<br />
Using rails-dom-testing 1.0.9<br />
Using crass 1.0.3<br />
Using loofah 2.1.1<br />
Using rails-html-sanitizer 1.0.3<br />
Using actionview 4.2.8<br />
Using rack 1.6.8<br />
Using rack-test 0.6.3<br />
Using actionpack 4.2.8<br />
Using globalid 0.4.1<br />
Using activejob 4.2.8<br />
Using mime-types-data 3.2016.0521<br />
Using mime-types 3.1<br />
Using mail 2.6.6<br />
Using actionmailer 4.2.8<br />
Using actionpack-xml_parser 1.0.2<br />
Using activemodel 4.2.8<br />
Using arel 6.0.4<br />
Using activerecord 4.2.8<br />
Using public_suffix 3.0.1<br />
Using addressable 2.5.2<br />
Using bundler 1.16.1<br />
Using climate_control 0.2.0<br />
Using cocaine 0.5.8<br />
Using coderay 1.1.2<br />
Using concurrent-ruby 1.0.5<br />
Using css_parser 1.6.0<br />
Using daemons 1.2.6<br />
Using eventmachine 1.2.5 (x86-mingw32)<br />
Using ffi 1.9.18 (x86-mingw32)<br />
Using htmlentities 4.3.4<br />
Using thor 0.20.0<br />
Using railties 4.2.8<br />
Using jquery-rails 3.1.4<br />
Using kaminari-core 1.1.1<br />
Using kaminari-actionview 1.1.1<br />
Using kaminari-activerecord 1.1.1<br />
Using kaminari 1.1.1<br />
Using liquid 2.6.3<br />
Using mimemagic 0.3.2<br />
Using multi_json 1.13.1<br />
Using mysql2 0.4.6 (x86-mingw32)<br />
Using net-ldap 0.12.1<br />
Using pandoc-ruby 2.0.2<br />
Using paperclip 4.2.4<br />
Using protected_attributes 1.1.4<br />
Using ruby-openid 2.3.0<br />
Using rack-openid 1.4.2<br />
Using rack-raw-upload 1.1.1<br />
Using sprockets 3.7.1<br />
Using sprockets-rails 3.2.1<br />
Using rails 4.2.8<br />
Using rb-fsevent 0.10.2<br />
Using rb-inotify 0.9.10<br />
Using rbpdf-font 1.19.1<br />
Using rbpdf 1.19.3<br />
Using redcarpet 3.4.0 (x86-mingw32)<br />
Using redmine_crm 0.0.34<br />
Using request_store 1.0.5<br />
Using sass-listen 4.0.0<br />
Using sass 3.5.5<br />
Using tilt 2.0.8<br />
Using sass-rails 5.0.7<br />
Using rich 1.4.8 from https://github.com/a-ono/rich.git (at master@93d1dd9)<br />
Using rmagick 2.15.4 (x86-mingw32)<br />
Using roadie 3.2.2<br />
Using roadie-rails 1.1.1<br />
Using thin 1.6.2 (x86-mingw32)<br />
Using tzinfo-data 1.2017.3<br />
Updating files in vendor/cache<br />
Bundle complete! 39 Gemfile dependencies, 79 gems now installed.<br />
Gems in the groups development and test were not installed.<br />
Use `bundle info [gemname]` to see where a bundled gem is installed.</p>

<p>C:\Bitnami\redmine-3.4.4-1\apps\redmine\htdocs&gt;rake redmine:plugins:migrate NAME<br />
=question_plugin RAILS_ENV=production<br />
<span style="color:#FF0000;"><strong>rake aborted!<br />
NameError: uninitialized constant QuestionHooksBase::Gravatarify</strong></span><br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/lib/quest<br />
ion_hooks_base.rb:3:in `&lt;class:QuestionHooksBase&gt;&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/lib/quest<br />
ion_hooks_base.rb:1:in `&lt;top (required)&gt;&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/lib/quest<br />
ion_issue_hooks.rb:1:in `&lt;top (required)&gt;&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/init.rb:3<br />
:in `&lt;top (required)&gt;&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/lib/redmine/plugin.rb:155:in `blo<br />
ck in load&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/lib/redmine/plugin.rb:146:in `eac<br />
h&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/lib/redmine/plugin.rb:146:in `loa<br />
d&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/config/initializers/30-redmine.rb<br />
:21:in `&lt;top (required)&gt;&#39;<br />
C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/config/environment.rb:14:in `&lt;top<br />
&nbsp;(required)&gt;&#39;<br />
Tasks: TOP =&gt; redmine:plugins:migrate =&gt; environment<br />
(See full trace by running task with --trace)</p>

<p>&nbsp;</p>

<p>사실 제가 요점이 흐려질까봐 다른 얘기는 안썼는데요..</p>

<p>&#39;bundle install -no-deployment&#39; 이라든가 재설치, 다른 플러그인 설치 등 구글링을 통해 이것 저것 해봤지만 정말 모르겠어서 글을 남긴 것입니다.</p>

<p>아무것도 시도를 안해보고 바로 글만 올리는 느낌이 들어서..^^; 오해하실까봐&nbsp;여담을 남깁니다.</p>

<p>&nbsp;</p>

<p>계속해서 도움 부탁 드립니다!ㅠ</p>

RE: Question 플러그인 설치 시 에러가 발생합니다. - translation missing: en.label_added_absolute_time_by

<p>Kim William의 덧글:</p>

<blockquote>안녕하세요. 먼저 환경은 다음과 같습니다. 1. OS : Windows 7 x86 2. Bitnami Redmine 3.4.4-1 (Windows installer로 설치) 3. Question Plugin은 &#39;git clone&nbsp;https://github.com/edavis10/question_plugin&amp;#39; 으로 받았습니다. &nbsp; 이후 Bitnami Redmin Stack Environment 에서 아래의 메시지들이 출력됐습니다. Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation. All rights reserved. C:\Bitnami\redmine-3.4.4-1&gt;cd C:\Bitnami\redmine-3.4.4-1\apps\redmine\htdocs\plu gins C:\Bitnami\redmine-3.4.4-1\apps\redmine\htdocs\plugins&gt;rake redmine:plugins:migr ate NAME=question_plugin VERSION=0 RAILS_ENV=production (in C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs) rake aborted! NameError: uninitialized constant QuestionHooksBase::Gravatarify C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/lib/quest ion_hooks_base.rb:3:in `&lt;class:QuestionHooksBase&gt;&#39; C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/lib/quest ion_hooks_base.rb:1:in `&lt;top (required)&gt;&#39; C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/lib/quest ion_issue_hooks.rb:1:in `&lt;top (required)&gt;&#39; C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/plugins/question_plugin/init.rb:3 :in `&lt;top (required)&gt;&#39; C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/lib/redmine/plugin.rb:155:in `blo ck in load&#39; C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/lib/redmine/plugin.rb:146:in `eac h&#39; C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/lib/redmine/plugin.rb:146:in `loa d&#39; C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/config/initializers/30-redmine.rb :21:in `&lt;top (required)&gt;&#39; C:/Bitnami/redmine-3.4.4-1/apps/redmine/htdocs/config/environment.rb:14:in `&lt;top &nbsp;(required)&gt;&#39; Tasks: TOP =&gt; redmine:plugins:migrate =&gt; environment (See full trace by running task with --trace) &nbsp; &nbsp; Rake Aborted 에러가 발생하는데 어떻게 해결해야 할까요... 구글링으로 아무리 찾아봐도 해결되는 방법이 없네요 도와주세요!</blockquote>

<p>&nbsp;</p>

<p>자체 해결했습니다.</p>

<p>혹시나 저처럼 레드마인 입문자 분들께 도움이 될까 해서 팁 남겨드립니다.</p>

<p>&nbsp;</p>

<p>저는 레드마인의&nbsp;무료 플러그인을 최대한 활용하여 커스터마이징 하는 것이 목적입니다.</p>

<p>그런데 플러그인을 설치하다 보면 위에 글과 같이 에러가 발생하기도 하고, 정상적으로 설치 됐지만 특정 페이지에서 에러가 나는 등의 문제가 많이 발생합니다.</p>

<p>제가 겪은 경험상, 이유는 다음과 같습니다.</p>

<p>1. 제공되는 플러그인의 버전이 너무 낮다.</p>

<p>git 주소로 제공되는 플러그인의 경우, master는 버전이 낮고 branch만 활성화 돼있는 경우가 있습니다.</p>

<p>이 경우에는 brach주소의 플러그인을 설치하면 해결되는 경우가 있습니다.</p>

<p>또한, 같은 플러그인인데 여러 사용자가 만들어서 제공하는 경우도 있습니다.</p>

<p>활동이 왕성한 플러그인을 사용하세요!</p>

<p>&nbsp;</p>

<p>2. 특정 플러그인에서 충돌이 발생한다.</p>

<p>일반 사용자들이 만든 플러그인과 RedmineUp 에서 제공되는 플러그인이 충돌나는 경우가 있습니다.</p>

<p>아직 해결 방법은 못찾았지만, 충돌 위치는 RedmineUp이더군요ㅠ</p>

<p>&nbsp;</p>

<p>도움이 될만한 팁일지는 모르겠지만.. 위 내용을 알아내는데 상당히 많은 시간이 소요됐습니다.</p>

<p>참고하세용~</p>

<p>&nbsp;</p>

<p>&nbsp;</p>

    (1-5/5)
    Add picture from clipboard (Maximum size: 500 MB)